Tunneling Route Reduction Protocol (TRRP)

 

--

Bill's workspace. Some notes he made while making sure the technologies really could be used this way.

modprobe ip_gre

ip tunnel add grem mode gre local 192.168.99.1
ip link set grem up
ip addr add 10.0.3.1/32 dev grem

ip tunnel add gret mode gre local 192.168.99.12
ip link set gret up

ip tunnel add grets mode gre local 192.168.99.12 remote 192.168.99.1
ip link set grets up
ip addr add 192.168.99.12/32 dev grets
ip route add 10.0.1.0/24 dev grets

ip tunnel add greds mode gre local 71.246.241.146 remote 208.69.4.21 key 0
ip link set greds up
ip addr add 192.168.99.12/32 dev greds
ip route add 172.16.0.0/24 dev greds

ip link set greds down; ip tunnel del greds

http://www3.tools.ietf.org/group/irtf/trac/wiki/RoutingResearchGroup

http://www1.ietf.org/mail-archive/web/ram/current/msg01761.html

interface Tunnel0
ip address 172.16.255.1 255.255.255.252
no ip redirects
ip mtu 1400
tunnel source 208.69.4.21
tunnel mode gre multipoint
tunnel key 0

interface Tunnel0
ip address 172.16.255.1 255.255.255.252
no ip redirects
ip mtu 1400
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 0

http://linux.die.net/man/7/raw http://linux.die.net/man/7/packet http://www.tcpdump.org/ http://www.packetfactory.net/projects/libnet/ http://en.wikipedia.org/wiki/Generic_Routing_Encapsulation http://www.cs.indiana.edu/cgi-pub/dmcgrath/classes/common/ansi-c-refcard-letter.pdf http://www.ietf.org/rfc/rfc1035.txt http://tldp.org/HOWTO/Divert-Sockets-mini-HOWTO-6.html http://www.retran.com/beej/sockaddr_inman.html

ip tunnel add mgre mode gre local 192.168.99.5 key 1
ip link set mgre up
ip addr add 10.0.3.2/32 dev mgre
echo 0 > /proc/sys/net/ipv4/conf/mgre/rp_filter